All motors controller skips steps

Hi, I bought the k8200 printer 3d one week ago. I finished to assemble and I’m trying it but the motors don’t work in right way. This is the situation: … rgenti.mp4 … rgenti.mp4

I controlled the wiring and the motor’s resistance and it’s all right. I’m sorry for my english.

Hi phoebe85,

I know it’s a lot I’m asking for, but could you post the resistances you measured on the motor connectors? E.g.

X motor, Pins …
1 & 2 = ?
1 & 3 = ?
1 & 4 = ?
2 & 3 = ?
2 & 4 = ?
3 & 4 = ?

Some of those should be infinite / open connections; feel free to combine them in order to save some lines of writing.

Please also doublecheck your power supply. Do you see stable 15 V (+/- 0.1 V maybe) on the power input screw terminal? At idle and, more importantly, also when the motors are used?


Extruder Motor: Rpin1&2 = 2.1 ohm
Rpin3&4 = 2.1 ohm

Z Motor: Rpin1&2 = 2.1
Rpin3&4 = 2.1

Y Motor: Rpin1&2 = 1.9
Rpin3&4 = 1.9
X Motor: Rpin1&2 = 1.4
Rpin3&4 = 1.4

Power supply: 15.48V

Thank you very much!

Hi phoebe85,

which reference voltage did you set on the motor driver boards?


I setted 0.425 V and after I tried to increase until to 0.55 V but it was impossible because the value restart from 0 V.

Excuse me for my english again.

Hi phoebe85,

that sounds like something is wrong with your motor drivers. Can you remeasure the Vref on one of the drivers? Make sure you get a good connection between COM probe and GND pin ("-" on the screw terminal), e.g. using a piece of cable and an alligator clip or something else that won’t fall off on its own. This way, you’ll also have both hands free for the +V probe and the screwdriver. Also, if available, use a ceramic or otherwise insulating screwdriver. The point for measuring the reference voltage is a small hole, a “via” to be precise, so the +V probe should easily have good contact there with no risk of slipping. When the voltage readout is stable, put the screwdriver on the poti and adjust the voltage.

If during this procedure your previous error returns, try to find out some more details. E.g. does it happen at the same voltage for all four drivers?


I tried this, but I had the same situation, the voltage Not Arrived To 0.55V. Tomorrow i send you a video that describe this.


Hi Kuraasu,
this is the video but it’s upside down…sorry: … 083920.mp4

Do you have this problem on ALL drivers?
At what position of the trimmer does it jump to 0V?

Hi phoebe85,

please retry the driver calibration with the motors connected.


Hi, I was able to calibrate motor drivers to a voltage 0.55 V. the problem is the y motor. I tried to swap connectors, driving the y motor with the other drivers and in this way the y motor works. The y motor doesn’t work. why?

I tried to upload the firmware v2 marlin ( … RLINV2.rar, as read on another topic) but does not go.The y motor still does not work properly.

Hi phoebe85,

did you short the JPROG pins before (and during) the firmware upload?

Was there an error message in the Arduino IDE?


I followed all the instructions.The firmware has been updated.

Hi phoebe85,

that sounds like a success, at least a partial one. As for the Y motor, could you describe in more detail what you mean by “doesn’t work”? You mention that it did work when powered by another motor driver, what about the other motor? Do you get the same error when you connect a different motor to the Y driver?