After update to M1-V1.1-H1: Auto home issues and restarts


After assembly with the factory settings and firmware version M1-V1.0-H2 everything was fine. Auto home raised the bed up to ca. 3mm below nozzle and x and y where in the right rear corner.
As I have just one nozzle I tried the update to Version M1-V1.1-H1 and had lots of timeout troubles. After several reboots of my mac it it finally worked and updated to version M1-V1.1-H1.

BUT: Now auto home does’t work as expected. Nozzle position has some offset in x and y dimension and printbed stopped some cm under the nozzle. Moreover each auto home restarts the board. It barely moves the motors anymore and then immediately restarts.
Manual x, y, and z axis moving is possible, however with some strange offset and limits in the possible moving range.

Printing seems impossible at the moment.
Can somebody please help?

Thanks. Can’t wait to have my first print …

Did you use Arduino 1.0.6 to upload the firmware? More recent versions have some issues.

Yes I used Arduino v1.0.6. on a MacBook Pro with OS X 10.10.3.
Compiling was no problem only the upload initially failed several times with some timeout errors from avrdude.
But Vertex displays firmware version correctly as M1-V1.1-H1.
It seems to be that auto home can’t correctly position the head and bed causing a restart, while manually moving the axis from “control printer” menu is possible. However the coordinates and movement ranges are also somehow flawed.

Any ideas? I will try to downgrade to M1-V1-H1 again, to see what happens.

Did you update the EEPROM values with the Load defaults/Store memory commands?

Yes I did. Sorry for not telling.
I also checked for the right board and serial port.
What else could I have done wrong.
I thought that maybe axis alignment is not good and the head get’s stuck, but I can move it around with the move axis commands without problems.

Now I successfully downgraded the firmware to M1-V1.0-H1. Same problems. It seems that auto home is not able to complete before the board restarts. Z-axis is not even moving at all while x and y are at least showing some move into the rear right corner (without reaching it really).

Now I successfully went back to factory settings firmware M1-V1.0-H2 and everything works fine - except that I don’t have a second head :frowning:
Also the newer two-head firmware does the auto home correctly and without restart.

But at least I know now that it’s related to the one-head firmware versions M1-V1.1-H1 and M1-V1.0-H1!

Strange that I seem to be the only one …

Now that I am able to compare the working version with the one before: The auto home behavior is very different. With the working version M1-V1.0-H2 the head moves back and forth in x and y direction (to properly detect the stop-ends i guess) as well as for the z-axis. The flawed one-head version doesn’t do that (but rather causes the board to restart).

What can I do? Can I transform the two-head firmware into one-head?

[quote=“ManMindMachine”]What can I do? Can I transform the two-head firmware into one-head?[/quote]Yes but logically it shouldn’t make any difference.
To find the differences you can run a file comparator.
In configuration.h the differences are :

#define EXTRUDERS 1 (instead of 2)

#define TEMP_SENSOR_0 10 (instead of 5)
#define TEMP_SENSOR_1 0 (instead of 5)

The ultralcd.cpp file is also different :

from line 522 to line 551 all commands #if TEMP_SENSOR_x are followed by >=0 in the H2 version and by !=0 in the H1 version
There’s also a line 1061 and 1070 commented in the H1 version (menu item for extruder 2)

The language.h file is the last different one (display HEADS: 1 or 2) on line 77

Yes you are right, but I did it anyway. :slight_smile: Actually it was a selective merge not overwriting all differences from the 2-head version.

  • Firmware (merged M1-V1.1-H1) uploaded successfully
  • Auto home works, no restart
  • After bed leveling, configuring Repetier Host with Slic3r (settings from screenshots and other sources), and slicing my first stl file (rod calibration tool) I was veeeery excited to see the printing start. :slight_smile:
  • But after roughly 15% completeness - BAM! My board restarts again and I will have to go to bed grumpy and clueless …

If needed I can provide (how?) my merged source code, but I have more and more doubts, that it’s just the code …
What exactly can cause the board to restart? Blocked stepper-motors? Currency fluctuations on the power line?

Btw: Thank you for helping me.

[quote=“ManMindMachine”]What exactly can cause the board to restart? Blocked stepper-motors? Currency fluctuations on the power line?[/quote] Power surges or noise can do that (switching on a fluorescent lightning, a starting motor - fridge … )

OK. Second try this evening to print the rod calibration tool. Unplugged the reset button first. And it successfully completed after 46min. :slight_smile:
Maybe just bad luck last time. Will try the next one with button plugged in again …