After MB replacement X&Y axis move 2x requested distance


Over 1 and a half month ago I bought a K8400 + an upgrade kit for a second head. I assembled it as instructed incl the firmware change for 1 head. Then I did the Z-calibration and loaded a PLA-filament. This went all ok. All motors worked moving them through the menu, though I never calibrated the distances the axis travelled.

Then I proceded to do the 2nd head upgrade. After installation of the 2nd head and it’s firmware I started the motherboard and checked for the firmware installation. Install ok.

Then unplugged the printer and installed the 5th driverboard (noticing the right orientation) after that the LCD did not even turn on. When I took it of the board, it did turn on and and the software booted. When moving around the driver boards while trouble shooting everything worked fine but only when the 5th board was not in place in any of the positions. When I placed everything back in the original position suddenly there was a puff of smoke from the motherboard and only the backlight of the LCD would light up (without the fifth driver board in place)and the mainboard would not connect to the computer anymore.

I created a trouble ticket (#935508) and sent in the parts.

So, after waiting for a month ([color=#FF0000]![/color]) I finally received a new mainboard and a new 5th stepper driver, yeay! I installed it all and besides the display, aparantly also broken when the mainboard broke (I’m told to send it in for replacement ticket #824625), everything seemed to work. But, when I started my first print on firmware version 1.1 for 2 heads and all settings default, as was installed by Velleman, I noticed the the X-axis was moving 2 times as far as requested. In effect my first try at printing a 6 x 6 cm print was not printed in the center of the platform and became 12 x 6 cm…

So my trouble shooting began…

  • I re-aligned the axis to make sure it wasn’t resistance related, without the belts in place the carriage moves even smoother, tilting the machine now shifted them.

  • I checked the ref. voltage calibration of the stepper drivers, all 5 were perfectly fine.

  • I installed the new firmware as recommended on the K8400 website, M1-V1.4-H2… and something changed… Now both the X and Y axis move twice the distance instructed, so a 10mm instruction moves X or Y axis 20mm?!?

  • I tried decreasing the number of steps per mm from the default 134.74 steps/mm to 67.37 steps/mm. This does work and a 10mm movement instruction moves either axis 10mm… However… I noticed that all my motors are warming up, don’t know if that’s normal though. But more alarmingly the stepper drivers at least for the X, Y and Z axis get to hot to touch after only a few movements and a couple of times homing…

I’m at a complete loss here, why isn’t it working using the default settings?

[color=#FF0000]It’s really frustrating and I feel like after 1 and a half month of trying to get it to work I’m still left with a 800 euro paper weight…[/color]

So please, Velleman, anyone, help me out here!


Kees Ricken

Did you already check the reference voltages set at the stepper drivers?
If not, check if they are set to the correct value. (like in the manual)
Too high reference voltage would give the motors too much current, heating up the motors and drivers.

For the double movement, check if the drivers are set to the correct microstepping value.
This is configured via solder “jumpers” on the driver boards. Maybe they are set incorrectly.

Hi, thank you gor the reply, As mentioned in my first post, I did check the ref voltage of all 5 drivers, they’re all well within the specification on your site.

About the micro stepping, how do I check that? Also, I do not think that this is the problem as before the firmware update the Y-axis was moving as intended and after, without any hardware change, it’s not, so same driver board…?!?

Which arduino Version did you use to compile and upload the new firmware?
Did you reload the default EEprom values in repetier after flashing?

And, just to mention, I’m not fom the Velleman team. :wink:

Hey Ichbinsnur, I saw you were not from Velleman, sadly Velleman isnt reacting much to this forum… Hope I wasn’t coming on to strong…

Anyway, I am using Arduino 1.0.6 as Velleman says to use. After flashing I have reloaded the EEPROM, nothing seems to work, besides halving the no# steps/mm which in turn heats up the drivers to almost untouchable temperatures… Weird stuff

Can you please unplug one of the stepper drivers that has this problem and post a clear,
high-res, picture of top and bottom side?
I don’t have a vertex myself, so that would help me to figure out the conmfiguration of the stepper modules.

Hey Hey,

My Z-axis is working normally, so 1mm move gives 1 mm travel on the Z-axis. If I switch my X-axis driver with the Z-axis driver of which I know it performs noramlly, nothing changes… so the X-axis kepps moving twice as far and the Z-axis keeps performing normally.

Anyway, these are the pictures of the X-axis driver.

I hope these are high-res enough, I have to make do with my I-phone 5s

[quote=“Wirecase”]Hey Hey,

My Z-axis is working normally, so 1mm move gives 1 mm travel on the Z-axis. If I switch my X-axis driver with the Z-axis driver of which I know it performs noramlly, nothing changes… so the X-axis kepps moving twice as far and the Z-axis keeps performing normally.

Okay, i didn’t know that.
That sorts out the stepper modules themself as source of the error.

Can you check if the solder jumpers (red markings) are all the same on your board?

Yes, they all look the same… I think there’s something in the firmware because of the change in behavior before and after the update, but i wouldn’t know where to look…

Can you check the voltage of the power supply on the green terminal block (on the controller board)? Everything getting so hot might be overpowered…

Hi raby, thank you for joining the discussion!

I did a readout of the voltage, it comes back at 15.05 volts for 3 separate measurements 1 minute apart.

So, this morning I decided to try and print using the new steps/mm settings (half of the default number of steps) for the X and Y axis… Within 1 maybe 2 minutes both axis stop moving intermittantly (at a higher frequency as the print continued) because the stepper drivers are overheating already… Stopped print to prevent damage.

What should look like this when I stopped the print

Came out like this, only part of the “brim” printed:

I’m getting fed up quick! Anyone any Ideas?

In short,

  • Both X and Y axis moved 2 times more than intended on the default settings.
  • Tried to fix this by halving the number of steps/mm, result: During homing and simple jogging the stepper drivers get hot and the motors get warm and first print looks like the pics above

I checked:

  • How well the printhead can move on the axis without the belts in place -> OK
  • Stepper driver reference voltage -> all ok
  • Mainboard input power -> nicely at 15.05 Volts
  • If the stepper drivers were ok by moving around to the other positions -> all seem ok, Z-axis moves normally, no matter which of the 5 drivers is driving them.
  • see this rest of the thread…

Thanks in advance!

You have a huge layer shifting.

I checked:

  • How well the printhead can move on the axis without the belts in place -> OK[/quote]
    Printhead moving well means moving from side to side when tilting the printer. If not the axis are ill tuned (check the alignment procedure in the [color=#408040]Wiki[/color]).
    Too much resistance on the axis can explain the stepper drivers and motors overheating.

Yes, correct, as I said, the layer shifting is because of the stepper-drivers are temporarily stopping because they’re overheating, it’s a thermal failsafe.

To confirm, yes, without the belts in place the printhead moves from side to side just by tilting the machine so that cannot be the problem. I first noticed this heating up of the stepper drivers after I changed the steps/mm… ?!? that cannot be right can it?

Sorry for the (extremely) late response.
reading all your posts I think it would be best to try and help you by telephone, I will send you my number in a PM.

Velleman “is on the case”!

Hi there,
We seem to have the same problem. Can anyone tell me the solution please?