A (sort-of) K8048 success story

Hi all,

before I start, I’ll freely admit I’m a complete noob to PIC’s and a relative amateur at electronics, so don’t ask me anything about them, but I am quite proficient at building things and soldering.

Yesterday afternoon, I bought the K8048 kit at one of a well known chain of electronics stores in the UK. Realising that my laptop doesn’t have a serial port, but thinking my Desktop does, I chipped in for a USB - Serial adapter too. (I’m not on my own here…maybe Velleman should CLEARLY state, on the OUTSIDE of the packaging, that a genuine serial port is compulsory!..Not a problem though, as I can use the adapter elsewhere.) We’ll get to this in a minute.

Anyway, I built the kit as per the instruction booklet, then made up the serial cable. I would like to suggest an amendment to the placing of the RS232 socket on the PCB…Could it be moved outwards slightly, in future PCB layouts, so that the male d-sub cover doesn’t have to be removed to make a connection? I’m digressing slightly, so back to building the kit…

Following the (mostly-correct) instructions, after reading the preceding page (5 for English-speakers) where it clearly states “AXIAL COMPONENTS ARE TAPED IN THE CORRECT MOUNTING SEQUENCE!” I was left wondering where ZD1 was. Again, an amendment could be helpful…“AXIAL COMPONENTS ARE TAPED IN THE CORRECT MOUNTING SEQUENCE! EXCEPT ZD1, WHICH IS PLACED LAST TO AVOID CONFUSION WITH D1 TO D7.”

Although the guide on soldering is quite good, where possible, I like to re-heat the pads on the component side and feed in a little more solder. This ensures a good contact, especially at C8, R21, R26, R27, R28, R31 and SW4, where PCB tracks are found on the component side. Maybe I’m being anal, but there is the possibility that a via is not connected during manufacturing…re-soldering component-side reduces the opportunity for problems to arise. Maybe this could be included on page 9, where the following line could be added…“The visible tracks on the component-side should be re-heated and re-soldered to ensure proper connection, following completion of the PCB-side soldering. Points of interest are C8, R21, R26, R27, R28, R31 and SW4”

This is especially relevant if you consider that this kit is available to ANYONE wandering through an electronics store, looking for something for young Timmy to focus upon for his future career and fortune. Mums
and Dads often ignore difficulty ratings, or don’t even see them due to the SMALL PRINT. This kit is no exception to marketing ploys. I don’t find “Advanced” printed anywhere that is visible on the outer package. It
is not until the kit is purchased and opened, that the customer is informed of the “difficulty rating”. And that is after the cash has been spent. How many parents are willing to spend further cash on ‘projects’ that Timmy ‘may’ not be competent to complete? How many parents are going to be wary of other Velleman products?

I digress again, so…Following the successful completion of the kit build, the next step was the Serial connection. Having removed the male d-sub cover and connecting to the K8048, I now ran into the USB - Serial adapter not allowing the PC to see the hardware. Research brought me here and the numerous problems were whittled down to components fitted the wrong way, in-correct PSU voltages being used, or the USB - Serial issue.

Reversal of components I can understand, as we’re not all competent electronics techicians and the packaging doesn’t really indicate an advanced knowlegde as a requirement.

PSU voltages - The instructions list, in the specifications, a power supply “12 to 15V DC, min 300mA, non-regulated adapter” then supplies a list of suitable PSU’s.

The USB - Serial issue. Again, nowhere on the outer packaging, does it state that a universal USB - Serial adapter is not sufficient for this application.

This is a bone-of-contention for a lot of the people who have bought this kit. Had it been CLEARLY stated that a USB - Serial adapter is not sufficient, I’m sure a lot of consumers would have opted for another (USB) PIC programmer. I would have and would not have had to construct a Serial - 10 pin header cable for my ASUS P5B Motherboard. With that said, however, my K8048 is now working fine and I can read from & write to the PIC without a hitch.

The only deviation I have made from the Velleman instructions, is regarding the PSU. Instead of using a 15.2V un-regulated PSU, I am currently using a ‘reclaimed’ ATX PC power supply. This PC power supply has pin 14 (Green wire in 20 pin plug - PS_ON…found to the left of the latching tag when looking at the pins) shorted to pin 13 or 15 (Black wire in 20 pin plug - Ground…found either side of the Green wire) This gives a 12V regulated supply using the Yellow wires for +12V and the Black wires for Ground. Some PSU’s need a load placed upon them by connecting a 10 Watt, 10 Ohm load resistor across the 5V rail (Red wire to Black wire). Others simply require a typical PC cooler fan, which is sufficient when connected to one of the Molex connectors. I Short the Green/Black pins and connect supply to the K8048/V111 BEFORE switching the PSU on.

The Velleman instructions request that an un-regulated, approved 15V PSU is used. I chose to use what I had at hand and it worked for me.

You are free to make whatever choices you wish. If you choose to ignore the warnings on a PSU, or other circuits that implicitly state “No user-serviceable parts inside”, you do so at your own risk. Capacitors in power supplies, cameras, TV’s and other electrical goods that display similar warnings, do so for a good reason…they can be lethal if handled improperly…even if the power lead has been removed many months ago.

I will not accept any responsibility for any injuries which may occur to any person adhering, or failing to adhere to any indicated warning on any apparatus that they are, or are not trained to operate on, with regard to the scope of this above text.



I would like to add that a fatal mistake would be having two pic’s plugged in different sockets. One would think that the crystal switching jumpers would thus only route one pic to the comms, but its not the case. Two pics plugged in will prevent anything from working.

As an aside I use an 18.9v powersupply I made from a transformer, a 4 diode rectifier, and a capacitor. It works fine.

I also had to replace the two diodes directly next to the 12 volt regulator, as the ones I received were not functioning on arrival (though I only found that out later after some frustration).

The large LED still flashes faintly for me in standby.

I could not use a USB to serial converter.

One computers serial port worked, another didn’t. Both are XP SP2 and fully updated. I would guess that different i/o chipsets are doing full software control of serial ports and some are doing a worse job than others.

I have successfully recreated lady ada’s minipov on a 16f630 using my k8048 programmer. I will now be tackling ICSP for the 16f877 as I have three of them kicking around.

I recommend in addition to the velleman software picprog2 (which works best for programming for me) WINPIC which has a k8048 compatibility mode. This program has very nice memory reading and visualising capabilities, and also has a very detailed log file generator which will help you solve all kinds of problems.

I have noticed that my pics right after programming can start running their progs in the prog rather than run position of sw5. This doesn’t worry me yet, but that might be a problem with certain firmwares…

Reply in your post within “K8048 - Software issues”

Can you provide more details (and a warning/disclaimer) for those who may wish to make their own supply?

Hmm, I haven’t had any problems with faulty components so far, but there will be some that get through.

AFAIK, LD9 should be COMPLETELY off in Standby…mine is.

You’re not alone. Many have been suckered into trying a converter. Not so much ‘Suckered’, more like personally suspecting that a converter will work in substitution of a real port. This has been a bone of contention in the past, where it has not been clearly stipulated on the outer packaging that converters do not work.

Your guess is as good as mine…can anyone else out there give recommendations as to which MOBO’s work well? I have two different ASUS MOBO’s, both using XP SP2, which both work with the K8048.

Thanks. Useful for those wishing an alternative to aid in problem-solving.

Not sure exactly whether this is a problem with your build, but I have never experienced this anomoly. Does anyone else have a similar experience??

Can VEL comment on this?

Strangely enough, on my own K8048, LD9 also faintly flashes while SW5 is in Standby mode, and a PIC is inserted.

But the programmer functions perfectly normally… Thus, I think the “LD9 faint flash” issue isn’t really one…

I think I may have bought my K8048 kit from the same large Retail electronics chain in the UK too, however the last purchase I made from them will be the last.
For one thing, check there is a warranty on the unit on purchase as I was informed that there was no warranty with it as it was self build only a DOA which would require the unit to be sent for testing before replacing or refunding. There was, however, a fully built version for roughly twice the price.
These are not the points I wished to address though.

I recently had to replace my motherboard (the reason said Retialer will see no more business from me) from an MSi 865PC Neo2-P which worked perfectly with this programmer.
I now have an Asus motherboard which just will not work on the serial port no matter what settings I use. I have tested on a friends machine and he gave me the settings which worked on his but they still do not work on mine.
BUT, I DO have a USB to Serial converter, no idea of make and model but the driver for a PL-203 USB to Serial adapter WORKS on this programmer on my setup.
It shows as COM port 7 but setting the software to this port works. Downside is a pic that should take around 30 to 40 seconds to program takes around 5 minutes but it does work.

Had the same issue with the DB9 socket on the programmer meaning it has to be either prised up or raised slightly before soldering in.

Now need to find software to support different pic chips to write to now too and already tried WinPic800 with no success either on actual serial or on USB cable.
Trying to currently write to 12F683’s but will continue to browse the forums on this point.