WSG150 Faulty ICs?

I have a class and they soldered this kit together. And then some of them finished and they were not working. Which is normal, so I had them go through double check with a multimeter and so forth. Then I checked and everything seemed fine. And I was stumped. Then more weren’t working and none of them were working. I have one that I made several years ago that works. So I swapped the IC and then the student’s project worked. They all worked with the old IC.

I stuck the new IC into mine, and nothing. I went through and stuck all 14 ICs into my older dice and nothing.

It’s been 2 days and still haven’t heard back from customer service. And the kids would like an answer I don’t have.

Hello @Kingspeak

Maybe the PIC12C508A are not programmed or have been erased due to electrostatic shock … or a defective batch …

I im sure the Velleman / Whadda team will try there best to solve your issues.
Have you contacte you reseller for an exchange ?

Or maybe you can try to write one chip with a custom programme via an Arduino ?

Have a nice day !

Still waiting to hear back from Whadda/Velleman…

I like the idea of the Arduino. I didn’t know that was an option.

Hello @Kingspeak,

I have seen your post in customer service and sended a reply.

We have checked the production. We have identified this problem.
The PIC’s had a wrong ID number while programming, so these are not working.
For which we apologize.

For others that experiencing the same problem,
Open a new ticket on customer care, via this link: Customer Care Velleman.
Add the invoice, photo of kit and PO number of kit.

Best Regards,
Velleman Support

1 Like