VMA 304 Failed to Initialize

Hi, I have read through the user manual for the VMA 304 and the topic posted here:

I still can’t get my SD card to initialize after following the code posted. Here’s the error:

Initializing SD card…initialization failed. Things to check:

  • is a card inserted?
  • is your wiring correct?
  • did you change the chipSelect pin to match your shield or module?

I am using an Arduino MEGA, on the guide it says CS should be pin 53 which is what I’ve been trying.
Don’t know why there are two pins for each SPI on the VMA 304 but I’ve tried both.
I’ve triple checked the wiring, the devices came in a 2 pack so I tried both devices no luck.

After realizing I forgot to connect the ground of my PSU to my Arduino I tried again, using just the Arduino.
I got this error:

Initializing SD card…Wiring is correct and a card is present.

Card type: SDHC
Could not find FAT16/FAT32 partition.
Make sure you’ve formatted the card

Running the code again goes back to the intialization failed error.
The SD card is brand new, formatted FAT32. I tried formatting it again, same issue.
If I remove the SD card and insert it again it goes back to the partition error.
Also tried again with the external PSU grounds connected and everything, same issue.

Update: It is not mentioned in the user manual, but I did try shifting the 5V logic of the MEGA outputs down to 3.3 V for the shield.

Any ideas what is going on here? It’s driving me nuts.



I don’t have one of these yet but look in this link.

I hope it helps

The issue turned out to be the logic levels, I hooked up my voltage divider backwards.

Still, the documentation on this part is pretty bare-bones, it would be nice if they mentioned that the SCK, MOSI, and CS lines all need to be 3.3 V.