Scratching surface when travelling

i know you understood but I just wanted to share a real photo of that said problem

Ok, this is first layer, it will be hidden. But it will do it to the last layer! And I doubt it’s very good for the nozzle itself and the coordinate system as it induces a vibration that might move the axis slowly

Thanks for the photo, that does help.

Especially on the top layer, the scratching doesn’t look good - I totally agree, that you should have a way to work around that.

As far as I can recall, the Vertex K8400 doesn’t cause scratches like this - every now & then, you can see a little trace - but nothing as significant as this…

I don’t expect that the nozzle will not have any noticable wear from it, though - but that’s not even that important… The fact that the print is being damaged is important, especially when it’s the top layer. And on tall builds, a friction like this could topple the print over & break it loose from the print surface.

I’d suggest you should try to bring this to the attention of the developer team… see what they can do for you. [crosses fingers]

Have you tried to recalibrate it?
Did you check the piezos

Many times recalibrated. The prints look good, no problem there. If it wasn’t calibrated correctly, the first layer would have problems or the whole structure would.

Yesterday this surface running did rip off a center piece that ruined a 7 hours print (ok, I was only mid way, but still)

The scratching is always a little present, but it should never interfere with the printing process or break a piece of your model. Are you sure the belts are tightened equally and enough? A loose belt can be the cause of this as the head will be at a lower position during travels than the software thinks it is.

I do not mean you need to crank the tightness of the belts way up but make sure they are properly tensioned.

when you move the sleds manually do you feel any resistance, especially between the different towers, like one is more difficult to move than another?

You can indeed increase the Z-hop variable in the slicer settings but the factory setting should be fine.



The belts are pretty tight, like, a belt should be (precision mecanician here) Can’t play guitar with them though, so, normal…

The towers have been aligned properly within a few 0.01mm and the sledges feel great when moving. Been working them very long with honing paste and cleaned them many times. They are fully adjusted now.

I don’t really get it though, because when I’m programming my CNC I make sure to have a z lift before travelling over a surface

Increasing z-hop setting does nothing in this case, it hops between print surfaces. It doesn’t hop when travelling from one point to another on the same surface

Increasing z-hop setting does nothing in this case, it hops between print surfaces. It doesn’t hop when travelling from one point to another on the same surface

Z-hop is executed together with a retraction command. When travelling within the same surface portion, a retraction is not requested by the slicer software. (I’m pretty sure that this is the case in most slicers: Repetier (with Cura engine) & Simplify3D are handling this the same, in any case).

@VEL327 Would there be alternative methods available to trigger the exuction of Z-Hop on head travel?


This may not help but thought I would ask.
Is this set in your configuration?

Yes it is set

As well as perimeter first

To me it looks like the combing feature of Cura… Actually Repetier lacks a ton of Cura settings, very interesting ones, imma drop repetier and use Cura instead I think

Might be a good plan, I’ve heard very positive comments on the new Cura slicer. Give it a go & post how you’re getting on? :slight_smile:

I’m on it :slight_smile: It’s getting late here, will print tomorrow

Well, after slicing, the difference is already to be seen, curious to print tomorrow! Yellow are fast travel movements, those usually scratching the surface

Top is Repetier, Cura slicer
Lower is Cura

I agree, that looks promising - looking forward to the results! :slight_smile:

Just to let know, I did not test print today, as I’m trying to get as near as possible to repetier time, so the results can actually be compared… As of now, the above was 17 minutes for repetier and 42 for cura solo, because I had ironing enable and a lot of things I shouldn’t for the test. Working tomorrow, so the test will come asap, if I find time tomorrow then tomorrow :slight_smile:

You can try the Cura slicer (not Repetier) the settings there are a little more advanced and the engine is a newer version than the one in Repetier. The manual has instructions on how to set it up for the Delta printer.

You can play with the settings in yellow, but we can only change the behavior of the slicer to an extent…


@VEL327 @Harry_D

Ok, printed both using:

Repetier - CuraEngine 0.2mm, no combing, infill 100% 45mm/s, z-hop enabled and avoid crossing printed areas enabled
Ultimaker Cura 0.2mm, no combing, no ironing, infill 100% 45mm/s, z-hop enabled

Repetier print time: 14 minutes
Cura print time: 19 minutes

Printing on a buildtek

My feel and impression:

  • Using Repetier I constantly heard the print head fast travelling over the surface on every layers. It was faster, but the end result, faces, is really poor in comparison to Ultimaker Cura. It did print the skirt. The printing order is chaotic, as for filling the face it mights start doing 45° lines in the middle, then jump in one corner, do a little, jump over to the other corner, do a little, then go back for a while in the middle, all that without lifting the print head of course, resulting in the surface scratching and approx 0.03mm vibrations on the main shafts.

  • Using Ultimaker Cura I heard maybe one surface travelling. The print was slower and I did not print the skirt. The printing sequence is VERY organized. If it starts at one end, it won’t do a little then go another place for a little printing. This resulted in less vibrations and a very convincing end result, much nicer visible surfaces. Yes, it did scratch the surface once, on the last layer, but once, which seems normal to me, not… 9 times as Repetier did

What’s next: I have deleted Repetier and Ultimaker as well as the gcode files from my computer, cleaned everything from them to fresh reinstall in order to test with a very basic pre made profile, not one that I changed over the course of time.

Some pictures? I think you’ll make it out who’s who :slight_smile:

That looks very promising, happy to read you found a solution.

Seems that Ultimaker’s Cura slicer is the way forward for you - well done! :slight_smile:

I am having the same problem with my printer. It scratches the surface really hard when travelling. The belts are tight and the bed is levelled. I am using cura as a slicer software and I changed the z-hop height. Does someone know how I can fix this?

Not sure if that helps, but if the printed surface is scratched, maybe this helps. It did for me.
This might be solved by using COMBING MODE. I faced an issue where the nozzle scratched the infill or top surface while travelling.

I used the below settings in Cura (4.5.0) and it seemed to work fine.

Instead having the nozzle move from “Postion 1” to “Position 3” scratching the surface slightly or oozing minor filament, it then moved via “Position 2” using the above settings.
Maybe that helps?

PS: Use Cura´s function to show the travel moves, change settings, and check the moves again. It may help determine needed actions in the settings… way before you start printing.
Good luck!