Repetier ignores my extruder choice


I can open a stl. place it on the workspace and choose the extruder which changes correctly the displayed color.
But after slicing it seems to use nearly random extruder settings however they are constant as long as i dont change anything.
This problem occurs with Cura and either with Slic3R

An example at the Vertex_bracelet.stl : I select extruder 2 for the letters and 1 for the rest. It is displayed in correct colors but after
slicing the letters belong to extruder 1 and the other parts to extruder 2. It seems to prefer extruder 2 but sometimes it takes
extruder 1 no matter which was choosed.

Does anybody know something about that?



I’ve found out a bit more now: Slic3R uses only his own settings, but when theres more the one object in the workspace
it takes extruder 1 for the Part with the lowest number…so if i want to change the extruder number of a part i have to change the Number off the Group or Part…

Unfortunately Cura has some even worse issues: I can select which extruder it should use for something but if I want to
print dual colored, for example the Vertex braclett, it shows it correctl but then it prints all parts with extruder 2, however
it does the 23,7mm offset correctly. So after printing theres a single colored object which has the secound layer shifted 23,7mm…

Can anybody help me? In the videos, vellemann seems to be able to print their own example stl dual colored…



Where can I get the old (1.05) Version of the Vellemann Repetier Host? As this is the only differenze to the Videos and tutorial…

Stupid question : did you load the firmware 1.1 for Dual head?

Yes, of course.

I’ve already printed succesfully dual colored with Slic3R but as theres no possibility to choose the extruders completly manualy,
I wanted to use Cura…althought it seems to be very bugy…

Are you printing from the SD card reader or from the Repetier host? This can happen (but normally shouldn’t as our curaengine config accounts for this problem) when you start the print with nozzle 2 in an active state.

First I would check if you are sure our curaengine settings are correctly loaded. Check the manual to make sure.

Mostly from SD but it appears in both cases.

The settings are the same as in the examples.

Edit: It’s working! I’m now using the ‘unbranded’ normal Version of Repetier with exactly the same settings…

[quote=“AVRuser”]Mostly from SD but it appears in both cases.

The settings are the same as in the examples.

Edit: It’s working! I’m now using the ‘unbranded’ normal Version of Repetier with exactly the same settings…[/quote]
I can confirm this is indeed a bug. Tried single extruder print with my dual extruder set up. Tried extruder 1, it was ignored and used extruder 2. Killed print, restarted and resliced object after selecting extruder 2. Same result.

Seems the only way to get back to printing single colour with extruder 1 is to reboot the board.

@Velleman - was this really tested before sending it out?

or simply using the normal Repetier version…

We can not replicate this bug. When printing from a PC the active nozzle is shown in the manual control window. Also when printing an object with one color with the second nozzle you still have to use VERTEX SINGLE HEAD print config. This profile explicitly targets the selected nozzle.

That is not made clear. There should be a note added to the end of the section about printing with two extruders to remind users to switch to single head config if they want to print in single colour with one of the extruders.

That explains why I got the wipe tower when I was testing single colour prints with each extruder - I thought it was something to do with the delicate model I’d loaded!

The manual states: When using the “VERTEX SINGLE HEAD” slicer configuration this acts like a printer with one head, so when you have a dual nozzle setup you can use this to print something with the second nozzle. Do not mix nozzles whent he “VERTEX SINGLE HEAD” slicer configuration is selected. Printing with 2 nozzles is explained in a later chapter.

To be clear:

When you are printing with one material (any nozzle) always use VERTEX SINGLE HEAD config.
When you are printing with 2 materials (support or 2 colors) always use VERTEX DUAL HEAD config.

When you are printing with one material (any nozzle) always use VERTEX SINGLE HEAD config.
When you are printing with 2 materials (support or 2 colors) always use VERTEX DUAL HEAD config.[/quote]
That’s my point, you should add those two lines under the heading “Remember:” at the end of the section on printing with two nozzles. The idea is to help users, not rely on them remembering something they read when they assembled their printer for one nozzle several weeks beforehand.

The issue that many people have is that their Support Extruder is set incorrectly. Setting this to Any Extruder should resolve the problem of selecting the left or right colour when using the Vertex Single Head options, even if SUPPORT is not required.


I don’t know if this is related, but might be - kind of…

I found that if you print with both nozzles for a dual color model, you can get the printer to choose the wrong nozzle by following these steps:

1: chose a dual color print from the SD card menu where it starts by using nozzle one
2: stop the print from the menu while nozzle two is active printing
3: ask printer to preheat both heads while you clear the board of the aborted print (I don’t know if the pre-heating makes a difference)
4: start print by choosing the dual color print from the SD menu again
5: printer will now use nozzle two in the beginning of the print (but move as if it was using nozzle one)

I don’t know enough about the details to spot if this is a problem with the generated G-code or if it is a problem in the firmware, but I would expect the firmware to reset its internal state for the printer head when you abort a print job, which is obviously doesn’t do.

Printing from SD card, firmware 1.1, Repetier v 1.0.6 - no PC connected


I have a similar issue.

I want to print a model using extruder 2 for support. I have a water soluble filament in this extruder.

However, the system ignores my attempts at setting this up.

I use the two extruder setting, and I also set ‘use extruder 1 for support’ setting.

There seems to be some form of nomenclature problem in repetierhost. sometimes the extruders are called 1 and 2, sometimes 0 and 1.

Any hints would be appreciated.

Really bad naming convention with one package and yet again a difference if you are using the LED panel.

I ended up naming my extruder’s Left and Right. Much easier to remember. Then I always assign the Lowest number available to the Right and the Highest number to Left. I always use the Left for the support filament.

Try that, it might help you.


It did help, thanks!

I tried renaming the Extruders, but Cura doesn’t show all the settings pages anymore. I renamed them back so now they show up fine.

With the initial names - I tried all the values for Support Extruder (0, 1, Any) - I wasn’t able to get the left head to be used for support.