Mk161 and mk162

Morning! I have a similar issue to a previous member - when I press button 1 on my remote, LD2 lights, and when I press the other button, LD2 still!

I tried to follow the advice but neither the receiver or transmitter will factory reset. The transmitter appears to fire both LEDs with either button, and when I hold both for 5 seconds the light comes on continuously but no flashing.

On the receiver I can change between pulse and toggle and can select different led, but whichever I pick, as soon as I send a command it fires LD2.

Please help! I want to impress my currently fairly unimpressed wife with my new remote control plasma screen lift , this is my first ever project, I’ve been up all night, I have burned hands and I am losing man points fast!! If I can’t fix it I’ll have a lift which only goes up…

Any advice gratefully received…

At this time, we have no experience with this problem, so we have no clue as to what might be the cause of this behaviour.

Check if the transmitter PIC receives 5V between pin 1 & 8.
Check if receiver PIC receives 5V between pin 1 & 8.
Make sure receiver power supply is OK (no excess ripple).
Test without load connected to output relays.

Thanks for the reply - I have tested and get the following results:

Transmitter - 5V between pins 1 and 8 when either button is pressed

Receiver - 2.85 steady state between pins 1 and 8, and voltage drops when I quickly press either transmit button, and will drop and remain at zero if I hold either transmit button down.

power supply is 12VDC, 2.3A, not sure how to check ripple

Haven’t yet connected any load - happy to work out issues with LEDs rather than 42" plasma TV elevation…

Voltage between pin 1 and 8 of receiver should stay at 5V at any time.
Check board for shorts, wrong part values, inverted parts, solder bridges, loose solderings etc…

Tried everything - the voltage regulator seems to have 12V in and 12V out which can’t help…

i think i have wasted enough time and money on this flawed endeavour so unless it’s a quick fix i shall buy a proper remote control

The voltage regulator is bad if his output is also 12V, or the ground signal is not connected.

The reason that the remote doesn’t work is because of an assembly error, but not due bad components !

don’t mind why it doesn’t work - looks like a duff voltage regulator, which i could replace, but it’s too much hassle, so thanks for your help but I will abandon my attempt to make it work.