K8061 problem

Hi!

I have a problem. I just assembled the card, and windows finds the card as it should be, connection is ok.

i can also read the version.

here are the problems:

  • cpu fail

  • neither analog or digital inputs / outputs work. (with the demo and diag sofware, measured)

  • The rx/tx light doesnt lit,also the run light doesnt lit. neither does the input / output leds.only lights working are the power on and usb leds.

i have tried to find bad weldings, but havent found, also with a meter i have measured the connections from the cpu and they are ok. i aint good in electronics, and a little help would be good.

so, where can i start looking for the fault? i suppose the ic3 is working correctly cause i can read the version from it.

Thanks in advance:

-Groovyb

It seems that the microcontroller IC6 is not working OK.
Have you checked its supply voltage. The voltage at pins 11 and 32 should be +5V.

Check also the capacitors C19 and C20. Should be 27pF.

hi!

the capacitors are ok.

i measured for the 5V, and found out that it stops to to IC1 and IC2 circuits, and doesnt continue to the J2 jump-wire. the pins in ic1 and ic2 are welded correctly, so now i am clueless.

the 5V comes correctly to ic1 and 2, but doesnt come out. i also tried to change the pic:s from 1 to 2 and so on, but still no outcome. what could cause this phenomenon?

thanks in advance:

-Groovyb

Is there +5V at the output pin of the voltage regulator VR1?

You can do the measurements without the USB connection to the PC. Just connect your power adaptor to SK2.
Please note that you have to connect your meter’s minus lead to some GND terminal of the connectors e.g. ANALOG OUTPUTS connector SK10.

Please note that the USB section is isolated from the rest of the board.

Hi!

i cannot get a reading from the regulator against the cards GND.

in the sk2, two pins are 12V against the third pin (-). the power source is working right, it shows 12V measured against the adapters - pin.

if i measure from the VR1 incoming pin (first) against cards gnd, nothing. against power sources minus, +12V. the regulators middle pin is gnd. third pin (outgoing) against analog gnd nothing, against power sources minus nothing. weldings are ok.

is the regulator broken?

also D1 measured as:

meters red to the stripe side, and black to the other, i get 12VDC

It seems that your power adaptor is outputting wrong polarity voltage.
There should be (+) in the middle and (-) in the outer sleeve of the plug.

Thank you!

that solved the problem!

i just remembered that i just used a japanese card which needed reverse polarity so i changed it. My mistake :confused:

now the K8061 is working like a charm!

little slow compared to the MCC:s (measurement computing) cards that i have used before :wink:

Nice that you got it working!
The diode D1 is put there just to prevent reverse polarity to destroy anything.

Take care!