K8048 problem with programming

I recently got interessted in programming PICs so i bougth the K8048.
I had some troubles first getting the ‘No device ID’ problem, but discoverd that i had switched places of T2 and T3.
After fixing that i have now succsesfully programmed my included 16F627 a couple of times.

However when i try to program a 16F84 it just goes
“Write error at: 0000

I have tried to disable the code protection, but that made no difference.
My current setup looks like this:
Real com port (tried different settings, like disableing FIFO and lowering the speed).
16V 4.5A Adaptor (tried a 13.5V 400mA at first and tought that was the problem).
Homemade serial cable (It worked with the 16F627).

It’s like the pic is write protected or something.
Anyone have any idea on how to solve this?

{from another forum user, not on behalf of Velleman.}

1] I think you will get better support by taking this query to the forums at www.microchip.com - it is about programming for the PICmicro, whereas the Velleman ‘programmer’ is for burning the resulting code into the microcontroller chip.

2] Have you adjusted the CONFIG word in the .asm source code you are compiling to suit the combination of the 16F84 and programmer you are using?

Thanks for answering.

1; I will try and do that, thanks for the tip!

2; Yes, I looked up and adjusted it, but the thing is when i try to write the new config word it just reads 3FFF back.
(the config word im trying to write is 3FFE, code protection off, Powerup timer is enabled, watchdog timer is enabled, and using an XT oscillator).

Ok seems it was the chip that was damaged, bought a new and it works flawless.