Hi I hope that someone can help me. I have a PCS100 that I bought a couple of years ago but have never used. I’m very sad as the first time I decide to use it I can’t get it to work properly.

I don’t seem to get a flatline trace out of it, I have tried shorting the input but the line is bouncing about all over the place. Also if I try the square wave test signal there are spikes all over the place.

I have tried two computers and have also tried different power supply units but still can not get a clean line.

Any suggestions on what I can do to correct it ?


One possibility to this problem may be that the GND is disconnected. Maybe the probe’s GND lead is broken.
What do you see on the screen if you disconnect the probe from the input BNC connector?
What happens if you short circuit the input BNC connector with a short piece of wire?

If no help then probably the GND is disconnected inside the scope. Use ohmmeter and check that there is connection from the input connectors GND to the centre leg of the trimpot RV1.

Thanks for the speedy reply.

I have checked and there is continuity between the ground of the probe and the center pin of RV1. There is absolutely no change in the trace between having the bnc connector shorted or left open.

Here is an example trace…

Does the spike appearance change if you slightly move the trace in vertical direction on the screen?

Yes it does change significantly if I move the trace vertically.

This indicates that the analogue-to-digital converter IC9 (ADS830) may be defective.
The bad thing is that it is an SMD component and it is very difficult to replace.

Please check the soldering of the following parts around the IC9:
C15, C17, C18, C19, C20, C24 and C25.

BTW: What is the general condition of the PCB? Is there visible any corrosion, moisture or dust etc. Some cleaning of the PCB may help in that case…

There does apear to be solder bridges on the IC between 11 to 12 and 15 to 16. I assume they are not supposed to be there. If not then how would you suggest is the best way to remove the bridges.


Those bridges are OK - should be there.

Nothing else suspicious found…?

If nothing found and if you are not going to send the scope to repair then you may try removing C17. – May help or may do the problem worse…

No nothing I can see that is obvious.

When you say send it for repair I assume that would be something I would have to pay for ?

You can return your scope to:

Velleman Kit Tech Dept.
Legen Heirweg 33
9890 Gavere

Thank you for the details but is this something I will have to pay for ?


Please include proof of purchase. If unit is less than 2 years old and if the problem is caused by a manufacturing error, then you will qualify for repair under warranty conditions. If not, a small fee will be charged, depending on the nature of the problem.

I’m afraid I have no idea how old it is probably more than 2 years and I would not have kept a receipt from that long ago. I don’t want to spend any money on it as I don’t want to put good money after bad so to speak. This is a Parallel scope so it is already out of date, spending more money on it is not the way forward.