A problem with slicer

When I open something (I’d draw my self in) in repetier it shows correct in the first 3d window, but when I slice it, the shape changes. I did try it with several 3d drawins but the all change in different shapes.


Could you post a picture of your issue? In the Slicer log is there something like “object is not manifold”?

What CAD software do you use? Some of them are exporting very bad .stl files.

you can use “netfab” for repair stl files and try again to slice it, it may work good

Hi, thanks for the responses. I use soldidworks to create my products.

This is the correct model I added to repetier:


When I slice it, this happens to it:


And in the log I have:
20:17:04.372 : OpenGL renderer:AMD Radeon HD 8250
20:17:04.372 : Using fast VBOs for rendering is possible
20:18:26.720 : Warning: The input file contains a hole near edge 377.000000-378.000000 (not manifold). You might want to repair it and retry, or to check the resulting G-code before printing anyway.
20:18:26.949 : => Processing triangulated mesh
20:18:31.956 : The model has overlapping or self-intersecting facets. I tried to repair it, however you might want to check the results or repair the input file and retry.
20:18:32.007 : => Generating perimeters
20:18:41.435 : => Detecting solid surfaces
20:18:42.011 : => Preparing infill surfaces
20:18:42.014 : => Detect bridges
20:18:42.019 : => Generating horizontal shells
20:18:42.054 : => Combining infill
20:18:42.054 : => Infilling layers
20:18:43.576 : => Generating skirt
20:18:43.593 : => Exporting G-code to C:\Users\Melvin\AppData\Local\RepetierHost\composition.gcode
20:18:50.843 : Done. Process took 0 minutes and 23.894 seconds
20:18:50.843 : Filament required: 615.7mm (4.4cm3)

You might want to upgrade Repetier to 0.90C you get a lot more information when you load the object.

I updated to 0.90C now and it seems to be slicing correct, so thanks. But now my printer doesn’t move anymore, or tells me the temperature. it says it is connected, but when I tell it to go to home for instance, it doesn’t.

It just stacks up the commando’s (I don’t know if that is the correct english word)

You’ll have to uncheck “reset on connect” in the printer settings.

I can’t find it, somewhere here?


can’t see a box to uncheck, I do see this tho:


Never mind, I found it. Thanks guys!!